Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - StarBank

Pages: [1]
1
"Play file" does exactly what it is supposed to do, "play one file". To play whole folders you should use the third item in the Play submenu - "Folder".

In the beginning I had difficulty finding the "Play" option (as I don't understand what "window-shade mode" is). I didn't find it by right-clicking on an empty section of the Playlist, nor by right-clicking in the list, but by right-clicking on the tiltle bar of the Playlist Editor. I think "Play" should be available by right-clicking anywhere, and more importantly, "Enqueue file" and "Enqueue folder" should be there too.

I understand that everybody has different habits when selecting what to play, and that no menu structure will satisfy the majority. I find the standard file navigation tools in all programs cumbersome and ineffective (especially if one has to go through a deep directory structure). This is why I have long abandoned the supposedly "user-friendly"  browsing interfaces of all programs and just use a separate file manager (Total Commander) to navigate and open my files, be it music, documents or work. Thus, if I want to play a folder (or enqueue several folders) in Wacup I just drag-drop them on the Playlist. Works 100% all the time and requires the absolute minimum number of clicks.

Um, did you actually read my post?...

Here, I'll quote it:
So, I first right-click on the playlist editor in window-shade mode, hover on "play", then left-click "folder". I navigate to the folder where the music is that I want to play. After I've selected the folder, I click "OK" in the open folder window. For some reason, it brings up the "open file(s)" window, which I don't want, because I want to play an entire folder of music.
In other words, when I right-clicked the playlist in window-shade mode (a.k.a. compact mode or whatever you call it when the UI for WACUP isn't in full, normal mode), I DID select the 3rd option ("folder") in the play sub-menu. I then navigated to where the folder was at in the "Add folder" window. I clicked OK in that "add folder" window. But, for some reason, that option didNOT play all the music files in the folder; rather, it opened up the "open file(s)" window instead, which is what I didn't want.

The thing is, I am able to select more than one file in the "open file(s)" window when I want to go that way as far as playing all the files in a folder. It just seems that, for some odd reason, WACUP isn't able to play all the music files that are in sub-folders within a main folder (which is how I have my music files organized; for Five Finger Death Punch, I have a main folder named for the band. Then, there are sub-folders within that main folder that contain each of the band's albums).

Edit: As I was finishing up this post, I tried the "add folders" option again, but this time, just for the hell of it, I tried selecting "recursive scan" in the "add folders" window, and that loaded up all the music files in the subfolders and even started playing them. So, not really sure what's going on...

2
I decided to try listening to the artist discography for Five Finger Death Punch.

So, I first right-click on the playlist editor in window-shade mode, hover on "play", then left-click "folder". I navigate to the folder where the music is that I want to play. After I've selected the folder, I click "OK" in the open folder window. For some reason, it brings up the "open file(s)" window, which I don't want, because I want to play an entire folder of music.

Then, I try putting the playlist editor in normal mode. I click on "add", then "folder". I select the folder I want, then click on "OK". The "add folder" window disappears, but the songs don't play.

I'm guessing that neither situation is supposed to play out the way it does. So, just thought I'd let you know.

3
Apparently, an issue I forgot to mention in the other thread (my apologies for the inconvenience) is that, when I have a bunch of songs loaded in the Playlist Editor, if I execute the "Previous track" feature twice fairly fast through either the keyboard shortcut (as in pressing the keyboard key to go back to a previous track twice within one second) or through the program's main window (as in clicking the "Prevous" button twice within one second), the program will skip past the last song loaded in the Playlist Editor and go to the second-to-last song.

I don't know if that action was something that was intended to be, or if it's something that was missed when the program was being developed. Regardless, just figured I'd let you know about this one as well.

4
Just did the upgrade install for the newest version.

Then, tested selecting more than one audio file at a time. The Playlist Editor loaded all the selected files and plays them.

Tested doing a fade-out in windowshade mode. The pop-up notification shows the song as having ended at the end of the fade-out.

So, I can report both issues as having been fixed.

Much thanks to you, dro, and the rest of the WACUP development team.

5
Don't worry; I completely understand.

It takes time and a lot of effort to get things right.

6
Luckily the stop with fadeout issue was a generic issue to all skins & yes "Winamp Classic" is what I meant only because of what I'd had reported the night before but that was me jumping the gun.

Both issues are now fixed for the next build. Thanks for taking the time to report them :)

-dro

So, just to be clear...

In other words, for the next build:
1) when I select multiple audio files through the instructions I described in the first post, the Playlist Editor will load & play all of them, rather than just showing the name of the folder they're in?
& 2) when I do stop with fadeout, when the fadeout ends, the song will actually stop, rather than the pop-up notification saying the song is paused & me having to actually execute the stop option to stop the song?

If so, then I'm glad the program will be back to normal for the next version.

And, I'm more than happy to report any issues I come across, as I look forward to WACUP becoming at least as good as WinAmp was in it's prime, if not leagues better.

7
General Discussion / Re: What's happened with winamp58_3660_beta?
« on: May 02, 2020, 11:36:23 PM »
They then released the non-leaked version in October 2018 which barely had had anything done to it in over 2 years & to add insult to injury they put it pretty clear placement on the redesigned Winamp homepage that the 5.8 beta (most ignore that detail that it's a beta) is "not an on-going project".

True, but the website also says they are currently working hard on a new version of the program.

8
Actually, the skin I've been using with WACUP since I first installed the previous build is "Winamp Modern".

So, by the sound of it, problems/glitches with the newest build aren't constrained to just the "Winamp Classic" skin (if that's the classic skin you're referring to).

9
OK, so, back when I was using the most recent stable version of WinAmp (5.666) before I switched to using WACUP, then after switching to WACUP, using the previous preview build for WACUP (1.0.11.5454), whenever I would 1) right-click on the Playlist Editor when it was in windowshade mode, 2) select "Play",  3) select "File", 4) select more than one audio file and, 5) click on the "Open" button in the open file(s) window, the Playlist Editor would load whatever audio files I had selected and begin playing them.

Well, after downloading the installer for the latest preview build, then doing an upgrade installation for WACUP to the latest build (in other words, installing the latest version over the prior one), when I now execute the above instructions for playing audio files, all the Playlist Editor does is show the name of the folder that the multiple audio files are in; it doesn't even play any of the files.
However, if I select a single audio file (rather than selecting multiple ones) when I execute the above instructions, the Playlist Editor loads the song and plays it.

The only way now I can get the Playlist Editor to load & play audio files is if, during my execution of the above instructions, I select "Folder" instead of file, then select the folder that contains the audio files I want to play, then select "OK" and wait for the Playlist Editor to load and then play the files.

Is the new version supposed to be this way? Or, during the changes made from the previous version, did the developers (maybe accidentally?) change some sort of code that now prevents me from loading and playing audio files the way I used to?

Edit: Oh, and another problem that's popped up for me as well: when I use the fade-out feature on a song in the latest build, in windowshade mode, the Playlist Editor registers the song as having been paused; it's only when I actually use the stop feature on a song (again in windowshade mode) that the song completely stops playing.

Pages: [1]