Latest restricted WACUP beta release is build #19100 (May 10th 2024) (x86 & x64 changelogs) | Latest WACUP public preview is build #19100 (May 10th 2024) (x86 only)


NOTE: Beta testers are added in a limited & subjective manner as I can only support so many people as part of the beta test program to keep it useful for my needs.

Unless I think you're going to be helpful, not all requests will be accepted but might still be later on. Remember that beta testing is to help me & the limitations currently works for my needs for this project.

Author Topic: [FIXED] Discord / emojis  (Read 9052 times)

kobochat

  • Newbie
  • *
  • Posts: 3
    • View Profile
[FIXED] Discord / emojis
« on: February 07, 2019, 06:32:48 AM »
I don't know if this was intentional or not, but if you put emojis in the rich presence text, only the first one shows up properly, even if all the emojis are the same. The rest show up as unknown characters
« Last Edit: September 16, 2019, 08:41:10 PM by dro »

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 4542
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Discord / emojis
« Reply #1 on: February 08, 2019, 04:10:50 PM »
Can you please attach a copy of you winamp.ini file as that will allow me to directly check the string you're trying to use. As such character should be ok as long as they can be UTF-8 encoded so it's possible there's an issue with the storing/parsing which your file should help me to diagnose.

-dro

kobochat

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Discord / emojis
« Reply #2 on: February 09, 2019, 03:33:58 AM »
I've changed it since the first message but this is after I tried to start both lines with the music note emoji, just as an example of the first one working but the second one not

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 4542
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Discord / emojis
« Reply #3 on: February 10, 2019, 10:40:35 PM »
Thanks for the file. I'm just having a look now as I see the issue with the second line being wrong whilst the first is ok (it doesn't seem to be related to a multi-line issue I found whilst checking it out when I made my prior reply). Will see what I can find now that I'm debugging it with your example.

-dro

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 4542
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Discord / emojis
« Reply #4 on: February 11, 2019, 01:35:16 AM »
I've determined the cause & I'm going to have to go over the ATF implementation to make sure it'll correctly handle the emoji so they'll work in all cases.

Good find even though it's going to cause me more work :)

-dro

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 4542
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Discord / emojis
« Reply #5 on: February 11, 2019, 10:15:33 PM »
I've gone over all of the ATF implementation & I believe I've now correctly made the changes needed so that the emoji type characters will be correctly handled whilst not breaking anything else. The fix will be included in the next preview build which should be out some point before the end of the month. Thanks for reporting this!

-dro