Latest restricted WACUP beta release is build #13286 (October 21st 2022) (x86 & x64 changelogs) | Latest WACUP public preview is build #7236 (March 11th 2021) (x86 only)


NOTE: Beta testers are added in a limited & subjective manner as I can only support so many people as part of the beta test program to keep it useful for my needs.

Unless I think you're going to be helpful, not all requests will be accepted but might still be later on. Remember that beta testing is to help me & the limitations currently works for my needs for this project.

Author Topic: WACUP output volume quiet, application and system think it's being loud  (Read 748 times)

Maktaka

  • Newbie
  • *
  • Posts: 1
    • View Profile
So, this was going to be a "how do I fix this bug" report, now it's just a regular bug report after a final hail mary attempt at a fix actually worked. So ignore the incorrect verb tenses in the first three paragraphs, I can't repro the bug anymore and it should all be past tense.

Across every song in my library (I've tested MP3s, OGGs, WAVs, and FLACs), WACUP's volume output is consistently lower than all other media players I have installed (original Winamp, MusicBee, Media Monkey, Windows Groove). Curiously, the volume mixer in Windows as well as WACUP's waveform seeker shows WACUP thinks it's actually being quiet loud. See attachment showing the waveform mixer and volume mixer in action, volume in WACUP is maxed, EQ is disabled.

If I turn on the EQ with the premixer boosted, I gain a bit of volume (still less than other applications), but the volume control of the DirectSound output kicks in and makes the volume warble all over the place because it still thinks its actually blowing my speakers out. Turning off the volume control on the output finally brings the volume up to match all other media players, but now the audio peaks and distorts constantly.

If this bug is affecting multiple media types then it's likely not an input plugin issue. I've tried using the WASAPI output plugin and restarting WACUP instead of DirectSound to no effect.

...oh, switching to WaveOut and restarting fixed it. And switching back to DirectSound (where I started in the first place) and restarting keeps the fixed sound output. Volume matches other players, no distortion from peaking. I... what? If toggling output fixes this, why did switching to WASAPI and restarting not do the trick? What's so special about WaveOut that it cleared this weird "play it loud at a low volume" bug?
« Last Edit: January 27, 2022, 05:50:29 AM by Maktaka »

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3875
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: WACUP output volume quiet, application and system think it's being loud
« Reply #1 on: February 11, 2022, 10:45:24 PM »
The different output modes due to the age of their api (e.g. waveout is essentially a Windows 3.x era api) will behave differently from how they scale the volume level between 0 & 100% (which is why some offer different modes for volume control) as well as whether it's applied to the process as a whole or if it's done relative to the process volume (as seen in the screenshot of the OS volume mixer).

waveout is one that affects the overall process volume if configured to do so with WACUP's plug-in or depending on the build it can instead be more like all of the other output plug-ins & just adjust the level of the audio data & that's then heard relative to the OS volume mixer. By changing to waveout & trying to play with things, it most likely forced the WACUP process volume to 100% so by changing to the other plug-ins, now what's output is a 1:1 mapping instead of being scaled within the OS volume mixer range.

-dro