WACUP

General => General Discussion => Topic started by: daniel_kukiela on October 26, 2021, 12:51:25 PM

Title: AAC playback?
Post by: daniel_kukiela on October 26, 2021, 12:51:25 PM
Can Wacup play streams/files in aac format?
Whenever I try to play either a local .aac file or use an url with aac codec, it simply does not play at all.
Am I missing anything in my system to let it decode the aac format?


Thank, you,
Daniel
Title: Re: AAC playback?
Post by: dro on October 26, 2021, 01:49:27 PM
Playing raw .AAC I don't remember that working though it's dependent on what in_mp3 (unless you've changed to use a different MP3 handling plug-in) is able to do. AAC streams should work but again is dependent on them going into in_mp3 - would need an example of one of the urls you're having issues with to double-check it.

-dro
Title: Re: AAC playback?
Post by: daniel_kukiela on October 26, 2021, 10:15:24 PM
I did not change anything yet nor added any plugins. This Windows 10 installation is rather fresh and I just installed Wacup on it.
Here's a stream example: https://stream.open.fm/127?type=.aac&user=800098929772&player_group=WWW


Thank you
Title: Re: AAC playback?
Post by: dro on October 26, 2021, 10:32:19 PM
It's because they're HTTPS urls & the in_mp3 plug-in (one of the last real bits from Winamp 5.666 that is needed for WACUP to work) doesn't work nicely with HTTPS. It also seems that the attempt to force the url to plain HTTP sort of works but it's then not continuing to be able to process the stream.

Nothing you're doing wrong, just a long standing issue when it comes to WACUP having to re-use bits of Winamp to operate for the current time :(

-dro
Title: Re: AAC playback?
Post by: daniel_kukiela on October 27, 2021, 05:12:58 AM
I was looking around here and don't know how much it matters, but both AAC file and stream work in Winamp. As much as I remember, your work is based on some older Winamp version which probably/maybe did not work with some newer AAC formats.

Ok then, I'll find some alternative for AAC, for now.


Thank you
Title: Re: AAC playback?
Post by: dro on October 27, 2021, 09:34:13 AM
I can only go by what I'm able to test & that doesn't involve trying things in the 5.8 beta as I refuse to install & test with that on principle.

Maybe there's a plug-in conflict going on though it showed as in_mp3 getting the stream with it trying to connect but then hanging as it seemingly couldn't make sense of things.

This is the downside to me still currently relying on using some of the prcompiled files from 5.666 & that WACUP is only at a beta/preview stage so things will be incomplete for a while to come.

-dro