Latest WACUP beta release is build #8282 (July 23rd 2021)

Latest WACUP public preview is build #7236 (March 11th 2021)

Author Topic: Bug: Performance drop when preview is opened.  (Read 682 times)

frogger5687

  • Newbie
  • *
  • Posts: 3
    • View Profile
Bug: Performance drop when preview is opened.
« on: December 22, 2020, 05:45:44 PM »
The application usually performs well, menus are responsive and visuals are quick to refresh.
This can be seen for any animation: play button, timer, oscilloscope, list navigation...
When either hovering over the winamp item on the main toolbar (winampPreviewBug0.png), or when using the alt+tab menu (winampPreviewBug1.png) the performance of these visuals becomes poor, and menuing becomes sluggish.

Sample video is also attached for clarification.



dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3027
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Bug: Performance drop when preview is opened.
« Reply #1 on: December 22, 2020, 06:15:21 PM »
There's changes already present for the next preview build later this week which should minimise the issue seen for both classic & modern skins when the taskbar preview is triggered. Annoyingly there's no obvious notification from the OS that we no longer need to provide the images & when using modern skins which are inherently slow to self-generate the image which is then rendered. that's what is causing the performance to tank once it's been triggered.

-dro

frogger5687

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Bug: Performance drop when preview is opened.
« Reply #2 on: December 22, 2020, 06:22:04 PM »
I had a feeling it had to do with double rendering.

Is it possible to include a configuration option to disable the preview?

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3027
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Bug: Performance drop when preview is opened.
« Reply #3 on: December 22, 2020, 06:51:13 PM »
It's not double rendering as such, it's just how things work with modern skins & what the OS wants (hindered by the main window seen not actually being the real main window which is what the OS will try to capture) that mean it's slow to get an image from the modern skin engine which the OS then is given.

Without that being done & just leaving the OS to do it's own thing, you get a random window shown despite it being much faster as the OS window cache is used. This is what happens if there's nothing done & it's not possible for WACUP to self-disable it & is something that can only be done via registry options & affects all program previews I believe.

All I can really say is see how it goes with the next build. The only other option is to use the custom thumbnail support (preferences -> general -> taskbar -> thumbnail image) & have that set to something like an image / now playing information instead of trying to show the main window.

-dro

frogger5687

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Bug: Performance drop when preview is opened.
« Reply #4 on: December 22, 2020, 07:08:26 PM »
Thanks for the information.

I don't use the thumbnail for anything in particular, just annoying when it happens on an alt+tab, or when hovering on the taskbar for too long.
I changed the custom thumbnail to a custom one, alleviates the issue for me.

Will retest this whenever the new build is available.
Thank you for the support!

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3027
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Bug: Performance drop when preview is opened.
« Reply #5 on: December 29, 2020, 03:08:22 AM »
Build 6800 was released a day after the last update to this so I believe it should now be working correctly.

-dro