Latest WACUP beta release is build #9478 (November 30th 2021) | Latest WACUP public preview is build #7236 (March 11th 2021)


NOTE: New beta testers are not currently being added as I need to re-work the beta test program

If you've not already requested to be a beta tester & would like to then please send a PM to 'dro' to be added to the beta test group.

Note: requests to be a beta tester are processed in batches when new beta builds are released so please by patient of this process.

Author Topic: Weird minor visual bug (also a typo)  (Read 1040 times)

dasdasgduiasgd

  • Full Member
  • ***
  • Posts: 10
    • View Profile
Weird minor visual bug (also a typo)
« on: January 09, 2021, 03:35:41 AM »
Ignore my edgy 90s colour scheme.

In the Bento theme and using the classic media library, if I scroll up or down fast enough using the scrollbar, I get visually duplicated list items. Selecting one of the "fake" items causes it to display the correct item, as does scrolling it off-screen and back again. I've managed to do it both on the artist and album sections, but not the song list at the bottom. This might just be because my arm is tired from jiggling the mouse. Much easier to trigger by accident than on purpose.

I've also managed it in the Winamp Classic and Classic Modern skins so I'm guessing it's unrelated to the skin.

I could be talking nonsense, but I'm guessing the bug is a result of some weird bug in the old winamp code being a tower of duct tape since it's been a problem for me even before I used WACUP?


Also there's a typo in the patrons thanks page in the preferences. It says "suggest that you have a look at the things their doing & creating.", but the "their" should be "they're".
« Last Edit: January 09, 2021, 03:46:29 AM by dasdasgduiasgd »

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3309
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Weird minor visual bug (also a typo)
« Reply #1 on: January 09, 2021, 04:04:45 AM »
I could be talking nonsense, but I'm guessing the bug is a result of some weird bug in the old winamp code being a tower of duct tape since it's been a problem for me even before I used WACUP?
You're talking sensibly & it's down to the media library core (gen_ml) from 5.666 & how it's doing the painting of the lists. As such there's nothing I'm going to do to work around issues from using that plug-in as it's time with WACUP is limited.

You could give the w.i.p. replacement media library core a go to see how that works (it's missing skinned menus & a few other things but it's testable). As there's things from gen_ml that my version are no longer doing like weirdness with trying to fast scroll through the lists being much less blurry / leaving artefacts. You can then revert back if you're still reliant upon artwork & the other bits not yet done but it'll be useful at this stage to see if things are better with the replacement as I believe it should be.

Also there's a typo in the patrons thanks page in the preferences. It says "suggest that you have a look at the things their doing & creating.", but the "their" should be "they're".
That's been there on purpose for far far far too long waiting for someone to notice it. I can finally 'fix' it :)

-dro

dasdasgduiasgd

  • Full Member
  • ***
  • Posts: 10
    • View Profile
Re: Weird minor visual bug (also a typo)
« Reply #2 on: January 09, 2021, 05:48:12 PM »
I switched to the new media library (at least according to the settings. It looks nearly identical after setting up the library so I'm not 100% sure. If it's meant to, well done on reproducing the look so well.), but it still occurs. One improvement is that clicking any item in the list seems to fix all of them at once now.


A couple of new small bugs seemed to show up once I changed over too:

When I imported my old library, my AC/DC tracks (and only those tracks) were missing the final letter on the artist and track tags, and other tags were blank. Clearing the library and scanning the folder to generate a new one fixed it.

If I highlight a track in the "songs" list, then select a different artist, that position in the list remains highlighted, unless there aren't that many tracks to show, which fixes it.

Also side note: I appreciate how responsive you are about feedback. It's a rarity.
« Last Edit: January 09, 2021, 05:48:50 PM by dasdasgduiasgd »

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3309
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Weird minor visual bug (also a typo)
« Reply #3 on: January 13, 2021, 02:14:30 PM »
Ok, I think you might have not enabled the thing I was referring to as there shouldn't have been a need to re-import the library. I'd meant going to Preferences -> Media Library & the toggle option on there (as it sounds like you went to Preferences -> Media Library -> Local Library). Is easily done & I should have been clearer at the time.

I'll have a look into the old import issue as that really shouldn't be clipping the string values like you've noted.

-dro