Turn Off Auto Play When Skipping to Next Track

  • 9 Replies
  • 387 Views
*

whosline07

  • Newbie
  • *
  • 5
    • View Profile
Turn Off Auto Play When Skipping to Next Track
« on: June 01, 2020, 10:37:28 PM »
I've turned off autoplay when restarting WACUP, but I can't figure out how to turn off auto play when I skip tracks. In the old Winamp, if you hit "Stop" instead of "Pause" and then skipped the track, it wouldn't play the next track unless you hit "Play." Whereas if you just paused, it would play the next track automatically when you skipped. Is there any way to have this functionality in WACUP, or is this behavior not possible yet?

Thanks for bringing Winamp back!

*

Aminifu

  • Beta Tester
  • Sr. Member
  • ****
  • 267
    • View Profile
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #1 on: June 02, 2020, 08:21:19 PM »
I'm using v5586 of the beta and do not have any of the autoplay options enabled. I'm also using auto advance when a track ends and advance to next track when the current track is stopped. For me the next track starts playing when clicking next when the current track is paused and doesn't start playing automatically when the current track is stopped. So for me, this works the same as it did with Winamp.

Are you using v5586 of the Preview Build?
Windows 10 Home 64-bit v2004
Logitech Z906 5.1 speaker system

*

whosline07

  • Newbie
  • *
  • 5
    • View Profile
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #2 on: June 02, 2020, 10:43:50 PM »
Turns out I was not using v5586, but after updating, nothing changed. I also have "Manual playlist advance" unchecked and "advance to the next track after the current one when playback stops" checked. Correct me if I'm wrong, but I think those are the settings you're referring to. If I hit "next" while a song is playing or "pause" and then "next," the next song plays immediately, which is fine. If I hit "stop", the current song stops and the next song is queued but not played. If I hit "next" again, the next song plays. My desired behavior, and the behavior of the old Winamp is that if I hit "stop," the current song stops and resets, but does not change. And if I hit "next" from there, the next song is queued, but is not played.

*

Aminifu

  • Beta Tester
  • Sr. Member
  • ****
  • 267
    • View Profile
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #3 on: June 02, 2020, 10:58:55 PM »
Ok, to get the behavior you want, disable (uncheck) the "advance to the next track after the current one when playback stops" option.
Windows 10 Home 64-bit v2004
Logitech Z906 5.1 speaker system

*

whosline07

  • Newbie
  • *
  • 5
    • View Profile
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #4 on: June 02, 2020, 11:31:11 PM »
When I do that, if I hit "stop" the current song stops and doesn't reset, but when I then hit "next" the next song plays automatically.

*

whosline07

  • Newbie
  • *
  • 5
    • View Profile
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #5 on: June 02, 2020, 11:33:21 PM »
Ok, so I found out there is a difference if I click "stop" in WACUP or if I use my media buttons on my keyboard. It works as intended within WACUP but not if I use my media buttons. I'll have to look into my keyboard settings. Thanks for working through it with me.

*

Aminifu

  • Beta Tester
  • Sr. Member
  • ****
  • 267
    • View Profile
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #6 on: June 03, 2020, 03:56:38 AM »
Yeah, getting keyboard media keys to do what you want can be tricky. It depends on the kind of keyboard (make and model) and how it is set up and how the WACUP Global Hotkeys options (in the General Preferences section) are set up. The default multimedia key support option works for me but I usually just use my mouse and click on stuff.

Good Luck
« Last Edit: June 03, 2020, 04:08:08 AM by Aminifu »
Windows 10 Home 64-bit v2004
Logitech Z906 5.1 speaker system

*

whosline07

  • Newbie
  • *
  • 5
    • View Profile
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #7 on: June 03, 2020, 07:09:07 AM »
For anyone else who may have this issue, I was able to do it by enabling custom hot keys and setting Playback: Next in Playlist to the Next Track button on my keyboard.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 2416
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #8 on: June 06, 2020, 01:21:22 AM »
From a quick read through things, I suspect it's due to me changing things around & the next on stop plug-in isn't reacting in the same manner. Though that plug-in is soon to be removed & the handling done directly which I'm hoping will resolve such quirks like this. I'm however not quite following the bit about the next hotkey & how that relates to things.

-dro

*

Aminifu

  • Beta Tester
  • Sr. Member
  • ****
  • 267
    • View Profile
Re: Turn Off Auto Play When Skipping to Next Track
« Reply #9 on: June 06, 2020, 05:09:06 AM »
I hope the OP will correct me if I'm wrong, but I think the next on stop plug-in is working as intended. Whosline07 issue had to do with getting different responses when using the mouse to click on playback controls vs using his corresponding multimedia playback control keys on his keyboard.

The curious thing about my keyboard is a missing multimedia playback control key. I have previous, next, play/pause, volume mute, volume increase and volume decrease keys, but no stop playback key. I do have a key (with a headphone symbol on it) that can be configured to open a program, webpage, or file, but I'd rather have a stop playback key.
« Last Edit: June 06, 2020, 05:22:36 AM by Aminifu »
Windows 10 Home 64-bit v2004
Logitech Z906 5.1 speaker system