Bugs in latest release - v1.0.9.5118

  • 5 Replies
  • 486 Views
Bugs in latest release - v1.0.9.5118
« on: March 01, 2020, 10:28:53 PM »
I'm using the Bento skin if it is of any help.

- Meta edit doesn't select selection (I already saw that other thread and know that it is a know issue, but it doesn't hurt saying it again :) )
- If WACUP is exited while a song is paused (or if it is still playing), it will automatically start playing upon next application launch. The desired outcome is the song being completely stopped upon launch (Behaviour in v5.666)
- The visualizer preset "Rovastar & Zylot - Crystall Ball (Many Vision Remix)" doesn't display anything at all. It's always just a black screen (I don't think that you can do anything about this but I just wanted to point it out anyway).
- WACUP crashes upon trying to unlock a visualizer preset (doesn't matter which preset, I am using MilkDrop 2 as the visualizer). By this I mean locking the current preset with "Scroll Wheel" and then unlocking it with the same button. Now I would send you a crash report but the program is trying to send it via Outlook but I don't have it set up (nor will I ever set it up :P ). Sooooo maybe export the crash report as a ".txt" so people can send it manually or attach them to these threads?

Anyway, I wish you best of luck with this project. Keep it up!!!

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 2336
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Bugs in latest release - v1.0.9.5118
« Reply #1 on: March 01, 2020, 11:03:32 PM »
Crash reports are auto-uploaded but it is also attempted to send it via email (bugs @ getwacup . com) so any additional information can be provided. Due to what's collected, it's put into a zip which can be found via Preferences -> Advanced -> Error Feedback (or the Crash_Reports folder within the WACUP settings folder if you know where you're looking). The emailing behaviour can also be disabled via that preferences page though I'd recommend against disabling it completely as its better for me to get any crash report than none :)

With the crash mentioned, I've just been looking through them & saw a number which seemed to be related to such an interaction & I've got that already fixed for the next build. If you want to send it over via email then I'll double-check it.

For the autoplaying feature, Preferences -> General -> Autoplay is where you can change the playback behaviour. 5.666 doesn't have any of that feature set which is why it's acting differently :)

The preset could be failing depending on the GPU being used as some don't like AMD setups & others don't like nVidia setups. It could also be causing a crash when DirectX is trying to process it which some do & it's done the better option of a blank render vs taking the whole process down (as older WACUP & Winamp builds would suffer). I don't know what's the specific cause until directly checking out the preset.

-dro
« Last Edit: March 01, 2020, 11:06:55 PM by dro »

*

jpolsan

  • Beta Tester
  • Newbie
  • *
  • 2
    • View Profile
Re: Bugs in latest release - v1.0.9.5118
« Reply #2 on: March 03, 2020, 10:01:01 PM »
Hi all,
I have found that using the latest release in Windows 10 x64 latest release: switched to the new Local Library plugin (instead of the old one), I can't add files to the Local Library at all. No matter how I try to do it, WACUP just won't add anything. This happens with the Winamp Classic, Winamp Modern and Bento skins at least (I've not tried them all but it seems that it doens't work with any...). If I go to "File -> Add Media to Library", nothing appears. If I try to drag the folder with all my music into WACUP, nothing happens either.

If it helps, all my local library resides in a mounted network drive as all my music library is in my local NAS.
When I switch to the legacy Local Library plugin everything seems to work and I can add my library.
Hope this helps. Thanks!

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 2336
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Bugs in latest release - v1.0.9.5118
« Reply #3 on: March 04, 2020, 01:05:40 AM »
That's expected as the replacement is lacking a lot of features including normal importing (it should have attempted to auto-import the existing legacy library) & is only included as a means for testing out its stability in earlier builds. Importing, etc is to be worked on in the coming months so that the legacy plug-in can then be finally dropped.

-dro

*

jpolsan

  • Beta Tester
  • Newbie
  • *
  • 2
    • View Profile
Re: Bugs in latest release - v1.0.9.5118
« Reply #4 on: March 04, 2020, 05:27:20 PM »
Ah, OK! I didn't know - now I do :)
Also, while talking about the Media Library plugin - you mentioned that there would be the capability to view the media library as a folder tree view of folders and subfolders.
I take it that has not been implemented yet either? I believe this topic is one one of the Beta testing forums but I don't have access to that (yet).
Please let me know.
Many thanks!
Jorge

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 2336
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Bugs in latest release - v1.0.9.5118
« Reply #5 on: March 05, 2020, 04:30:55 PM »
Correct that's not yet been started on though I've done some preliminary work on how to try to quickly fill the tree view part of it (which would then drive a sub-query purely related to the selected folder) but that's as far as it's gotten. You should also have beta access now :)

-dro