[WIN7 / INSTALL WEIRDNESS | RESOLVED] Issues with integrated Crossfading

  • 9 Replies
  • 155 Views
*

Azrubel

  • n00b
  • Newbie
  • *
  • 5
  • Intelligence chases after me, but I am faster.
    • View Profile
I've been using Winamp for around 18 years now, so I kinda know my way around some functions I use a lot. Crossfading is one of those, and even so this issue got me pretty bamboozled.

Every time I try to turn the crossfader on, it says it is "not supported" and that I have to activate DirectSound as output plug-in. Every. Time. Even when Nullsoft DirectSound Output v2.64 is already set as active output plug-in (and is the only output plug-in enabled, btw).
I had to enable fading directly from DirectSound settings (first time ever I had to do this in the dozens of times I installed Winamp).
If I turn off the crossfader, and then try to turn it back on, it again gives me the "not supported" message; to fix it I have to go into Nullsoft DirectSound settings again and just clic in any of the options of the list, to make the plug-in "remember" that it already has fading enabled... The "Enable" checkbox appears greyed as if it were not available, but when I clic the list it magically goes back to normal. I click OK, close preferences and voilà, crossfader back online.

Now it is active and it's working. If I don't touch it, it'll be fine. But that doesn't make it less annoying, lol.
« Last Edit: February 14, 2020, 04:29:01 PM by dro »

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1989
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Issues with integrated Crossfading
« Reply #1 on: February 07, 2020, 09:31:10 PM »
What skin are you using? The only thing I can think off is that the delayed loading of the output plug-ins WACUP does which has been present for a few builds might be conflicting with a skin check (unfortunately I've not been able to replicate this myself at the moment with what will become the next preview build).

-dro

*

Azrubel

  • n00b
  • Newbie
  • *
  • 5
  • Intelligence chases after me, but I am faster.
    • View Profile
Re: Issues with integrated Crossfading
« Reply #2 on: February 07, 2020, 10:53:24 PM »
Forgot to mention, I'm using Modern Skin at the moment.
You say I test the thing with another skin to see if it still happens?

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1989
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Issues with integrated Crossfading
« Reply #3 on: February 11, 2020, 04:43:17 PM »
You can try though it's generally Winamp Modern & Bento based skins that have the integration with that plug-in.

It might be better seeing what the next preview build behaves like as there are changes to how output plug-ins are loaded which might be the cause of the issue you're having.

-dro

*

Dr.Flay

  • Evil Genius
  • Beta Tester
  • Jr. Member
  • **
  • 99
  • AMIGA Forever
    • View Profile
    • About Me
Re: Issues with integrated Crossfading
« Reply #4 on: February 11, 2020, 05:14:59 PM »
I get it a lot since the bug crept in.
Generally I click on the option to change the settings then go into the DS out prefs
After checking if the time value in the skin and plugin match, which it often does not I click on the  OK button and it should behave again for the session.

I just checked now and the end of song timing is on 0 ms but the skin is still set to my last choice of 5 seconds.
Corrected then close and reopen WACUP and yep, back to 0 ms again.
My weekly radio show on Source FM ☛ 15% Extra

*

Azrubel

  • n00b
  • Newbie
  • *
  • 5
  • Intelligence chases after me, but I am faster.
    • View Profile
Re: Issues with integrated Crossfading
« Reply #5 on: February 12, 2020, 07:20:30 PM »
Yep, tested it with all the moders skins and it's still there.
I was starting to think that it could be my install was botched somehow or my plugin broken, lol.
Anyways, if crossfading is active and I don't touch it at all, "it just works"™.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1989
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Issues with integrated Crossfading
« Reply #6 on: February 14, 2020, 02:46:30 PM »
Preferences -> Advanced -> there's an option related to the settings cache. Try disabling that & then seeing if the issue persists after restarting WACUP.

-dro

*

Azrubel

  • n00b
  • Newbie
  • *
  • 5
  • Intelligence chases after me, but I am faster.
    • View Profile
Re: Issues with integrated Crossfading
« Reply #7 on: February 14, 2020, 04:02:21 PM »
Huh, didn't get to try...
Before, I was running Windows 7 Ultimate x64 in this machine (drivers and codecs up to date, tho). Yesterday I did a fresh install of Win 10 LTSC x64.
I just installed WACUP in the new system and there is no sign of the problem. Turning the crossfader on or off and tweaking it from DS setings  did nothing strange; is working as intended.
Could it be something related to Win7 or DX11? Or a problem derived from some specifics of my old system. No idea.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1989
    • View Profile
    • WACUP (Winamp Community Update Project)
Re: Issues with integrated Crossfading
« Reply #8 on: February 14, 2020, 04:10:41 PM »
I know Win7 could sometimes incorrectly apply compatibility shims related to modern skins though you'd not seemed to be having the issue I know that causes. Maybe there was just a weird config related issue going on that starting afresh negates. Main thing is that you're not having the issue.

-dro

*

Azrubel

  • n00b
  • Newbie
  • *
  • 5
  • Intelligence chases after me, but I am faster.
    • View Profile
Re: Issues with integrated Crossfading
« Reply #9 on: February 14, 2020, 04:17:36 PM »
Yeah. Thanks a lot for the assistance <3 I'll keep a eye out for any other weirdness.