100% CPU load when playing linein://

  • 4 Replies
  • 655 Views
*

Nitorami

  • Newbie
  • *
  • 2
    • View Profile
100% CPU load when playing linein://
« on: November 03, 2019, 02:16:36 PM »
Hi there
As of lately, when I select linein:// and press play, the PC gets sluggish, with CPU load close to 100%. No visualisation, just playing stereomix. Process Explorer indicates that the main load is caused by explorer exe; within the explorer, the main load is in shcore.dll.
When playing from CD or disk, this does not happen.

Same with all winamp versions as well as the wacup preview version. I am using windows 10 version 1903. Possibly this came in via a recent windows update, but I cannot revert to an older version to try. Issue is the same on my father's PC which is also at version 1903.

My only solution to this is to kill explorer.exe, and to restart it when I need the desktop back...

Martin

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1898
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: 100% CPU load when playing linein://
« Reply #1 on: November 11, 2019, 11:00:04 PM »
Hmm, considering Winamp & WACUP are using different plug-ins for doing the linein:// handling so I'm a bit stumped especially as why something in the shell would be involved.

What skin are you using or is it a skin agnostic issue?

-dro

*

Nitorami

  • Newbie
  • *
  • 2
    • View Profile
Re: 100% CPU load when playing linein://
« Reply #2 on: November 12, 2019, 07:29:46 PM »
Hi DrO
I'm rather oblivious of skins and usually just keep the classic one. But, I just revisited the issue, and it does not seem to reoccur with WACUP. Sorry, I may have got confused with all the versions I installed and deinstalled.
The problem still reliably persists with winamp 5.8, fresh install, default settings, classic skin, and I'm fairly certain it is related to a windows update, as I would have noted it before. My father's old machine in particular, which used to work smoothly, now hardly responds at all when milkdrop is playing linein://
I will change to wacup.

Just for curiosity, I observed that WACUP is running CPU heavy milkdrop presets at a faster rate than winamp. That does not come for free, the CPU load also goes up proportionally. I have always ticked the "loosely enforce frame rate" box, so something seems to have changed in the fps control.

martin
« Last Edit: November 12, 2019, 08:11:26 PM by Nitorami »

*

Gordon Freeman

  • Wannabe Modern Skinner
  • Beta Tester
  • Jr. Member
  • **
  • 58
    • View Profile
Re: 100% CPU load when playing linein://
« Reply #3 on: November 12, 2019, 07:43:39 PM »
It sounds like it's using the onboard GPU for graphics stuff, do you have a dedicated graphics card for both computers, and if yes, have you updated the drivers?

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1898
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: 100% CPU load when playing linein://
« Reply #4 on: November 12, 2019, 08:25:08 PM »
Well at least I don't need to investigate the linein:// issue further :)  I've not used the 5.8 beta so can't really comment but it's unlikely to be different from what 5.666 uses which was a crude solution (the wacup version is based off jasper's great input plug-in).

The Milkdrop build with WACUP basically differs in that it fixes an issue it had where it was artificially limited to ~80fps maximum. Now it can now run at higher fps for those with the appropriate hardware but it's otherwise meant to keep itself maintaining existing limits so there shouldn't have been a real change. I just can't remember if I changed the default fps on new WACUP installs or not from 30 to 60 or didn't change anything. Unless it's related to some of the fixes that allow shader model 3 to work on both AMD & nvidia devices (which the non-WAAUP Milkdrop cannot do).

-dro