[FIXED SLOW LOADING AS OF PREVIEW v1.0.6] new preview build slow to start-up

  • 11 Replies
  • 224 Views
*

bembe

  • Newbie
  • *
  • 6
    • View Profile
Hi.
First of all, thank you for your hard work.
I've been using Wacup since January and everything works great but one thing bothers me - slow startup. It's not a big application but it loads 9-10 seconds on my fast machine while Winamp loads instantly. Is this startup normal or something isn't as it should be? I don't have any 3rd party plugins extra installed.
« Last Edit: September 15, 2019, 04:54:28 PM by dro »

*

The1_Freeman

  • Beta Tester
  • Newbie
  • *
  • 45
    • View Profile
Re: new preview build slow to start-up
« Reply #1 on: August 27, 2019, 12:20:51 PM »
Hi.
First of all, thank you for your hard work.
I've been using Wacup since January and everything works great but one thing bothers me - slow startup. It's not a big application but it loads 9-10 seconds on my fast machine while Winamp loads instantly. Is this startup normal or something isn't as it should be? I don't have any 3rd party plugins extra installed.
please create a new thread, dont reply to pre-existing ones about your issues

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1798
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: new preview build slow to start-up
« Reply #2 on: August 27, 2019, 03:51:04 PM »
I've split the post into it's own thread from where it was initially posted.

What skin is being used as such a time is not expected & the nearest I can get is with the BBM skins taking around 6-7seconds for everything to load (which is just the nature of more complete modern skins). Also is the slow start-up an issue also with the prior preview build ?

-dro

*

bembe

  • Newbie
  • *
  • 6
    • View Profile
Re: new preview build slow to start-up
« Reply #3 on: September 02, 2019, 11:14:55 AM »
Sorry for the wrong post followup.
I'm using Big Bento Modern Window 10 Edition.
Prior this latest preview build - January edition - was the same. As I sad, Winamp loads instantly, while Wacup takes circa 9 seconds longer.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1798
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: new preview build slow to start-up
« Reply #4 on: September 02, 2019, 12:20:19 PM »
What skin are you using in the Winamp install?


Other than using a different skin there's not much else I can suggest.as the currently selected skin offers so much but it comes with the cost of slower loading due to how the modern skin engine works.


-dro

*

bembe

  • Newbie
  • *
  • 6
    • View Profile
Re: new preview build slow to start-up
« Reply #5 on: September 02, 2019, 08:19:25 PM »
In Winamp I used modified skin by me (based on cPro skin/plugin). It wasn't so quick as default skin but insignificantly slower.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1798
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: new preview build slow to start-up
« Reply #6 on: September 02, 2019, 09:23:05 PM »
What is the loading speed of your own skin like under WACUP?

As you don't need to re-install cPro as it's included with it so you should just be able to copy of the skin folder / archive & try it out without too much effort.

-dro

*

bembe

  • Newbie
  • *
  • 6
    • View Profile
Re: new preview build slow to start-up
« Reply #7 on: September 07, 2019, 05:22:10 PM »
My skin is also slow, even maybe second slower..
though my skin doesn't work (some parts are like broken) nicely in Wacup like Big Bento Modern Window 10 Edition.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1798
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: new preview build slow to start-up
« Reply #8 on: September 07, 2019, 05:34:18 PM »
There is going to be a change in the next build that should resolve some of the slow loading issues with modern skins (is a combination of Winamp doing the wrong thing & Windows 10 having changed some of it's behaviour).

What's broken about the skin? I need to know specific details in case it's a regressions with the cPro engine or if there's something that WACUP has unintentionally changed.

-dro

*

bembe

  • Newbie
  • *
  • 6
    • View Profile
Re: new preview build slow to start-up
« Reply #9 on: September 07, 2019, 06:09:06 PM »
I've tried it now with Classic Winamp skin and it start instantly... but the skin is to small to use on my large monitor and it's stilistically not my cup.
My skin has playlist background white in Wacup (while it should be grey as the rest of the elements) - but it is not important, don't worry because I'm amateur in skin editing and could be that I edited something badly back in the days when adjusting other authors skin to my needs.
Thank you for the effort to "speed" things. I'm looking forward to the next build!
All the best.
Bembe
« Last Edit: September 07, 2019, 06:11:03 PM by bembe »

*

bembe

  • Newbie
  • *
  • 6
    • View Profile
Re: new preview build slow to start-up
« Reply #10 on: September 15, 2019, 01:03:40 PM »
The new preview build 1.0.6 is great!
Now it starts almost instantly.
Thank you very much for your effort Dro!
Cheers,
Bembe

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1798
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: new preview build slow to start-up
« Reply #11 on: September 15, 2019, 04:53:56 PM »
That's great to hear it's starting instantly with the new build, yay heh.

-dro