WACUP won't start

  • 27 Replies
  • 2014 Views
*

Deacon

  • Beta Tester
  • Newbie
  • *
  • 21
    • View Profile
Re: WACUP won't start
« Reply #15 on: February 13, 2019, 10:34:32 AM »
I have this problem too, so I've gone back to normal winamp until it's sorted.
Just seems to occur randomly. Does open every now and then. Normally use the quicklaunch or desktop shortcut to open it.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1739
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: WACUP won't start
« Reply #16 on: February 13, 2019, 03:59:04 PM »
Deacon: what build were you using it was it any of the recent builds ?  If there was a way for me to quickly replicate the issue then I would fix it but as I'm honestly struggling to replicate this whilst it happens so consistently for others is really leaving me stumped as apart from the quirks I know off, there 's no reason when just doing a straight shortcut load without any additional parameters / files being passed for it to lock-up / not load. Unless there's something like the A/V present that's blocking the process loading.

-dro

*

Deacon

  • Beta Tester
  • Newbie
  • *
  • 21
    • View Profile
Re: WACUP won't start
« Reply #17 on: February 14, 2019, 07:53:38 PM »
Deacon: what build were you using it was it any of the recent builds ?  If there was a way for me to quickly replicate the issue then I would fix it but as I'm honestly struggling to replicate this whilst it happens so consistently for others is really leaving me stumped as apart from the quirks I know off, there 's no reason when just doing a straight shortcut load without any additional parameters / files being passed for it to lock-up / not load. Unless there's something like the A/V present that's blocking the process loading.

-dro


I’ve been using various builds from November or so, and it’s been an issue with every build. Just grown a bit tired of it for now!
I’m using eset antivirus but I’ve never had any problems with it making problems with any other apps, and get no notifications.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1739
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: WACUP won't start
« Reply #18 on: February 14, 2019, 08:13:24 PM »
I really wish you'd have said something to me at the time unless I'm just not matching up the forum account to email / discord messages as I'd not been aware of consistent failure to start issues prior to putting out the public preview builds :(

I'll up my attempts to try & determine what's going wrong & even hopefully replicate the issue though so far none of my test setups show a loading failure :(

-dro
« Last Edit: February 14, 2019, 08:20:21 PM by dro »

*

Deacon

  • Beta Tester
  • Newbie
  • *
  • 21
    • View Profile
Re: WACUP won't start
« Reply #19 on: February 15, 2019, 12:17:53 AM »
I really wish you'd have said something to me at the time unless I'm just not matching up the forum account to email / discord messages as I'd not been aware of consistent failure to start issues prior to putting out the public preview builds :(

I'll up my attempts to try & determine what's going wrong & even hopefully replicate the issue though so far none of my test setups show a loading failure :(

-dro

Sorry about that. I was more assuming it was my computer or something, but done a fresh install and and still the same. I’ll have a faff about with it at the weekend myself and see if I can work out anything.

*

pimento

  • Newbie
  • *
  • 11
    • View Profile
Re: WACUP won't start
« Reply #20 on: February 15, 2019, 08:15:08 AM »
In my case I don't have any AV outside of what's built into windows 10. At this stage I can't think of any additional factors that might be affecting things, outside of perhaps being that it's more likely to happen if I don't open WACUP up until much later in the day.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1739
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: WACUP won't start
« Reply #21 on: February 15, 2019, 12:31:12 PM »
@Deacon: I've split your new posts into a thread that I've moved into the beta discussion forum due to some of the data that's been posted.

@pimento: that's interesting if it's better later in the day. though can you have a look in the system event viewer & see if there's any winamp/wacup reported errors (I've a feeling that what Deacon has posted before I split the posts might be the same sort of cause of issue).

-dro

*

Deacon

  • Beta Tester
  • Newbie
  • *
  • 21
    • View Profile
Re: WACUP won't start
« Reply #22 on: February 15, 2019, 12:33:45 PM »
Cheers. Hopefully we can work this out!

*

pimento

  • Newbie
  • *
  • 11
    • View Profile
Re: WACUP won't start
« Reply #23 on: February 21, 2019, 03:57:22 AM »
@Deacon: I've split your new posts into a thread that I've moved into the beta discussion forum due to some of the data that's been posted.

@pimento: that's interesting if it's better later in the day. though can you have a look in the system event viewer & see if there's any winamp/wacup reported errors (I've a feeling that what Deacon has posted before I split the posts might be the same sort of cause of issue).

-dro

Sorry, I explained badly, it's more likely to not open later in the day. I just tried it now and it's failing to open, I had thought perhaps it was related to being docked but I'm on a work trip so no dock here. Anyway, the first time it started the two background tasks as usual and didn't load, I killed them and tried again, that time it didn't even load the tasks but I got two entries in the Application log (nothing in the system log) and then I tried again and it was back to the two background tasks and nothing else. I've attached the details from the two events here.

*

Juanus

  • Beta Tester
  • Sr. Member
  • ****
  • 302
    • View Profile
Re: WACUP won't start
« Reply #24 on: February 21, 2019, 04:09:06 AM »
Sorry if I missed this before.
But what version of windows are you using?
And if you are on Windows 10, which update are you on?

*

pimento

  • Newbie
  • *
  • 11
    • View Profile
Re: WACUP won't start
« Reply #25 on: February 21, 2019, 11:08:25 PM »
Windows 10 pro 64-bit 1809 on a Surface Pro 3.

*

dro

  • Admin / WACUP Developer
  • Administrator
  • Hero Member
  • *****
  • 1739
    • View Profile
    • WACUP (Winamp Community Update Pack)
Re: WACUP won't start
« Reply #26 on: February 21, 2019, 11:22:19 PM »
It's the same bad_module_info error that Deacon is experiencing. The temporary solution for that seems to be just running as an admin all the time (which really isn't ideal). I've got to make a debug build to try & work out where the loading failure then happens as it running under admin but not a normal user is somewhat baffling.

-dro

*

pimento

  • Newbie
  • *
  • 11
    • View Profile
Re: WACUP won't start
« Reply #27 on: February 25, 2019, 03:30:08 AM »
I'm happy to run a debug build for a time if you would like more data on it, just let me know! In the mean time I'll continue with launching it as admin when necessary.